Fuel leak on holiday - urgent!

Discussion in 'Mech Tech' started by dazzaxjr, Aug 24, 2011.

  2. There's definitely fuel in the tank. Everytime I undo the fuel lines it goes all over me. :)

    Just spent 1 more hours removing the new pump and fitting the old empi Chinese marmite one. Van
    Now runs but for how long?

    So dunno what to do. Will run the old pump for a few days and see what happens. To be honest I have no other choice right now.

  3. check the new filter and the pump are on the right way round. did you get any fitting instructions?
  4. Instructions were sparse I have to honest. Only making on pump said "out" on one end so I connected that to the carbs.

    I took off the filter and could blow through both ways, but fitted with the larger end as "out" as per the usual plastic ones.

    Like I said empi one works with pipes and filters I have so assuming duff pump at the mo.

  5. the new pump is definitely running when you have the key on yeah? maybe it takes a bit of time for the pump to prime?
  6. Yep, with power you can feel it running, but with power or without flow rate is about the same. :(

    I installed a fuel filter after the pump and it didn't fill with fuel when the pump was running. With the old empi pump it fills maybe 3/4 and runs up to about 35mph. Above that it stutters and dies.
  7. Had a thought. Is it ok to test pump using water?

    It would be a lot easier and safer.

    Cheers. Darrell.
  8. So I think the next step is to test my new pump with a couple of jugs of water am see which way it pumps. If at all. ;)
  9. ditch the filter you have after the pump.

    this is how it should look;

    tank > filter > pump > carbs

    job done.

    If you've got twin carbs make sure you have the pipes all connected properly. Anyhow, I thought you had breakdown? Get them to do it
  10. Thanks joker. I have breakdown but they can't find a garage that will look at it.

    The one place I did find installed the pump that failed after a few hours so in no hurry to go back.
  11. Experiment 1:

    Here's the setup.

    Top bucket has water, bottom is empty. Pump in middle connected to coil.

    Turned on and hums away but does not pump. Swopped the buckets over still nothing. Removed the filter and tried again, still nothing.

    Looks like this pumps DOA. :(
  12. how long did you leave it for? by swapping the buckets over you mean you tried the pump both ways?
  13. Left it about 30 secs each aide in turn trying to draw water from the full bucket.

    Didn't work either way.
  14. Hmmm think I'll repeat the experiment tomorrow with the faulty (old) pump as well. Although it means taking everything off again.

    If my suspicions are correct it will pump a little water, but not enough to drive 2xdellortos.
  15. don`t forget you have a bit of pressure already from the tank ,so the pump may have to be primed...

    ie washing up bottle upsidedown connected or container on a chair and suck the pipe to create a bit of pressure first..
  17. Do you have to prime these pumps? If assumed that the pressure of fuel from the tank would fill the pump to get it started.

    Certainly there's nothing in the instructions for either pump about having to prime them first.

    Just trying to avoid a mouthful of petrol. :(
  18. a bit late now, but see ebay.co.uk item no. 270737735011
    thought they were supposed to be unobtainable.
  19. sorry scrap that- looking more closely dont think it is for a type 4. I should leave it to the experts.

Share This Page